Recovery to Hyper-V guest "No"

The place to discuss any technical issues or suggestions in relation to BackupAssist v9.

Recovery to Hyper-V guest "No"

by dlevasseur » Mon Apr 04, 2016 11:55 pm

In my backup report under the "Recovery" section I see "Recovery to Hyper-V guest "No".

I'm confused what this means. Everything else comes up green, hyper-v backups all show good.

Also since I'm here. In the backup report under "Hyper-V" the table shows each VM Name, Status, VM Size, ETC. 2 of my VMs are showing as 0.00B for size. The other 3 VMs report many GB of size.

:?:
dlevasseur
User
 
Posts: 11
Joined: Wed Jan 08, 2014 2:02 am

Re: Recovery to Hyper-V guest "No"

by Stuart » Thu Apr 07, 2016 10:15 am

Hi there,

It's Stuart here from the BackupAssist team, thanks for posting on our forum.

Are you backing up the actual physical host running the Hyper-V role? If so, then what you're seeing is normal as you're unable to restore a host machine within a guest as it's not possible to run the Hyper-V role within a guest. If that's the case, then what you're seeing is expected. :)

As for your second comment, I'd need to see the actual backup report and also know the specific configuration you have for Hyper-V in your environment to be able to answer.
Are you running any form of clustered environment?
Are you running any form of deduplication on the source data?
Are the VM's reporting as being backed up online or offline? If so, is this different to those which are displaying the data?
When you check the monitor screen during a backup, is there anything abnormal with those guests?
Stuart Edwards
BackupAssist Support

*Have you tried restoring from your backups lately?*
Stuart
Cortex I.T.
 
Posts: 998
Joined: Tue Sep 02, 2008 2:25 pm

Re: Recovery to Hyper-V guest "No"

by dlevasseur » Fri Apr 08, 2016 6:14 am

Stuart, Thank you for the reply.

I am running BackupAssist from the Server 2012 R2 host machine and backing up VM guests. So I think that is "As expected"

As for the "VM Size (Source)" numbers...

Yesterday I noticed that 1 of the two servers reporting 0.00B the day before now had a size (33.14GB). And then today it is now reporting a size for every guest. Both reports had numbers for "Total Size" of each VM in the "Backed Up Items Log". All VMs are performing Online backups.

I think everything is good to go. I'm actually scheduled to test the backups tomorrow, so I guess I'll see if they are working.
dlevasseur
User
 
Posts: 11
Joined: Wed Jan 08, 2014 2:02 am

Re: Recovery to Hyper-V guest "No"

by Stuart » Fri Apr 08, 2016 9:39 am

Hi again,

Yeah, if you're backing up a physical host then it can't be used in a P2V situation...basic rule is if you see anything other than a No on a Hyper-V host then the report is incorrect.

My guess is that something occurred within that specific backup you first referenced where a size value wasn't passed correctly from Hyper-V to BackupAssist.
If the guests are listed as backed up, then I would put this down to the report not displaying the information more so than the guests not being in the backup.

Good luck with the restore testing, if you need any help with it then make sure to contact our support team and we'll be able to assist where required.
Stuart Edwards
BackupAssist Support

*Have you tried restoring from your backups lately?*
Stuart
Cortex I.T.
 
Posts: 998
Joined: Tue Sep 02, 2008 2:25 pm


Return to Technical Support v9



Who is online

Users browsing this forum: No registered users and 0 guests

cron