Page 1 of 1

Resolved - Can't Deploy BackupAssist via Multisite Manager

Posted: Mon Apr 11, 2016 11:51 am
by Janika
I've been trialing backup assist and have just recently installed the multi-site manager trial to go with it. Straight away I am having issues deploying the client via multi-site manager. I have tried googling the error message but there are no results, and no specific error code either. The error is the same for all 3 entries.

My set up is as follows:
Multi-site manager and Backup assist are installed on a VM. I have then attempted to add the VM host, a VM hosted on the same VM host, and a physical server box. They all ended up with the same error.

I have attached a picture that hopefully explains better than I have:

Image

Re: Can't Deploy BackupAssist via Multisite Manager

Posted: Mon Apr 11, 2016 1:48 pm
by Stuart
Hi Janika,

It's Stuart here from the BackupAssist team, thanks for posting on our forum.

With the way BAMM works, the web console is not directly connecting to the individual machines when you perform the update.
The web console will connect to the site controller you have configured which will then be instructed to push out the update to the nodes connected directly to the site controller.

The error that's being generated appears to be due to an issue with the BackupAssist Service on the site controller where it's unable to be stopped during the process.
What I'd recommend is logging into the site controller directly and checking the BackupAssist Service under Contol Panel > Administrative Tools > Services.

I'd even restart the service if it's showing as started just to refresh everything.

Once you've done this, try running the update again from the BAMM console to see if the service restart has helped. If you continue to have issues, log into the machine using the user which you have blanked out in your screen shot and make sure that the service can be stopped properly - if any error appears (most likely permission based) then this will be why BAMM isn't able to update the software correctly either.

Re: Can't Deploy BackupAssist via Multisite Manager

Posted: Mon Apr 11, 2016 4:22 pm
by Janika
Thanks Stuart - that is exactly what I did. I went to the site controller and restarted the offending service. That gave me green ticks for 2 out of the 3, the third gave a different error message - but when I logged in to that server, it was actually up to date, so just an error with reporting rather than with the install.

Re: Can't Deploy BackupAssist via Multisite Manager

Posted: Tue Apr 12, 2016 9:04 am
by Stuart
Hi again Janika,

Glad to hear that you've been able to update as required.

Just curious, was the error that you saw after the update on the one particular machine related to the service not starting or similar to a timeout based error?
If so, I have seen similar with some particular machines the service takes longer than expected to start which then throws an error.

It's something that I've put in to be reviewed for a future release to try and remove this from occurring.

Re: Resolved - Can't Deploy BackupAssist via Multisite Manag

Posted: Fri Apr 15, 2016 4:02 pm
by Janika
I believe it was the service not starting - unfortunately I didn't make a proper note if it as it was fixed once I double checked, and my trial is expired now so not able to run the install again!