Exchange Backup Job

The place to discuss any technical issues or suggestions in relation to BackupAssist v9.

Exchange Backup Job

by MSD » Tue Jan 05, 2016 12:26 am

Hi all

We are having some problems with Exchange related backups. We have a System protection backup that backs up all volumes which executes on a daily basis (which 90% of the time works fine).

However we also have another system protection backup, but this only backs up exchange. It has been scheduled to take a snapshot at 8am, 12:15pm, and 4pm. This is so we are never too far behind email wise should the worst happen to the server. This initially seemed to work fine, then for no apparently reason that i have identified it seemed to stop working.

I have increased the Exchange consistency checks from 5min (default) to 15mins which matches what our main daily job has, however this still doesn't seem to like it.

We are running SBS 2008, and are backing upto a NAS device on the same network. Both jobs use the same credentials, and go into the same shared folder, just at slightly different levels. This user has full access rights. I can't understand why the job is failing after the consistency check has completed.

The VSS mode is set to: Full VSS Mode (exchange application logs will be pruned)

========================================================
Log
========================================================
Retrieving volume information...

This would backup volume New Volume(E:) to \\NAS\Backup\Exchange-Backup_System-Protection.

Backup to \\NAS\Backup\Exchange-Backup_System-Protection is starting.
Running consistency check for application Exchange.

Backup stopped before completing.

Summary of backup:
------------------
Backup stopped before completing.
Access is denied.
========================================================

Does anyone have any ideas as to why the daily seems to work okay, but the Exchange job doesn't work?
MSD
User
 
Posts: 5
Joined: Wed Oct 21, 2015 7:09 pm

Re: Exchange Backup Job

by Stuart » Wed Jan 06, 2016 12:39 pm

Hi there,

It's Stuart here from the BackupAssist team, thanks for posting on our forum.

There will be a backend difference between the two jobs. The first job that is performing a full system backup will be performing a 'volume' level backup and working from a block level of the physical drives.

Just backing up part of the system (just as you are with the Exchange backup) changes this to be a file level image instead of a volume level. The reason for the problem is as the logs state - Access is Denied.
My guess is that there are some files involved with Exchange where the Backup User Identity (Settings > Backup User Identity within the BackupAssist console) doesn't have the full permissions available to back up Exchange specifically in that format.
You say that this second job worked fine in the past - if it did suddenly start failing then there must have been something occur on the system (updates, someone changed access rights, etc). that is most likely the reason for this occurring.

I'd also recommend taking a look at the event logs within your system through Event Viewer. Specifically you are best off to check the backup logs which can be found by browsing to Applications and Services Logs > Microsoft > Windows > Backup within the Event Viewer console.
Stuart Edwards
BackupAssist Support

*Have you tried restoring from your backups lately?*
Stuart
Cortex I.T.
 
Posts: 998
Joined: Tue Sep 02, 2008 2:25 pm


Return to Technical Support v9



Who is online

Users browsing this forum: No registered users and 1 guest

cron