Page 1 of 1

Drive gets dismounted

Posted: Wed Jan 13, 2016 9:06 pm
by dns
After using Backup Assist for a while we had a sudden issue were the drive got dismounted during a backup and now trying to mount it there is a volsnap 82 error in Event Viewer:
"Volume G: is offline for shadow copy protection. A shadow copy meta data corruption was detected. Please try clearing the protection fault or restart the computer. If all else fails, revert out of shadow copy protection mode to reclaim the use of the volume while losing the shadow copies."

The computer (Windows Server 2008 R2) has been restarted with no luck. The drive comes up as RAW so no dskcheck or accessing the drive is possible. Tried internet research and points a lot to System Center DPM which we don't have.

Anyone come across this issue and ways to resolve it?

Re: Drive gets dismounted

Posted: Thu Jan 14, 2016 12:49 am
by casey.burns
Hi there,

My name is Casey, and I'm with the BackupAssist team. Thanks for posting on our forum.

From the sounds of it, you currently have SPM (Shadow Protection Mode) enabled in BackupAssist. To turn SPM off:
Open BackupAssist > Manage > double-click job > Imaging options.

Once you've turned off SPM, retry the backup and see if the problem continues.

If you already have SPM turned off, you'll need to send in a diagnostic through BackupAssist for further assistance.

I hope this helps, please let me know if you have anything further to add.
Kind regards,

Casey Burns
BackupAssist Support

Re: Drive gets dismounted

Posted: Thu Jan 14, 2016 1:48 pm
by Stuart
Hi there,

It's Stuart here from the BackupAssist team.

I saw your post and figured I could help you past this. I encountered an issue the same within our testing environment today.
The only way to get past this is to run diskpart and clean the drive to allow SPM to release the drive so it can be used again.

I'd also review the following KB article regarding SPM and it's intended use: http://kb.backupassist.com/articles.php?aid=3385.

Re: Drive gets dismounted

Posted: Mon Jan 25, 2016 7:28 pm
by dns
Thanks, seems that disabling SPM worked for the future backups (on a new partition) and prevented the drive from becoming corrupted. Tried everything to get the old drive out of protection mode and working again but couldn't. Only option was to copy the content of the drive using recovery software (GetDataBack to be exact) and then delete the partition.