Page 1 of 1

Recovery Failure

Posted: Wed Dec 10, 2014 8:49 am
by SAFCasper
Hello,

Just had a trial run at restoring a backup of our SBS2011 server to new hardware and unfortunately had no success.

- Booted recovery disk
- Connected our backup drive (USB2 Hard drive)
- Chose "Recover from backup located on local drive"
- It finds the drive and finds all previous backups etc.
- Looking at the "Excluded Drives" section I can see my target drive is present, but not excluded. Can also see and access the drive via diskpart command.

So I begin the restore and within 20 seconds it fails with this error.

Failed to find enough suitable disks for recreating all critical disks. 0X80042408


Now I only backed up the C: drive as it's the only "Critical volume" as described in the BackupAssist Wizard. This is a single 500GB SATA drive. There is a another 1TB drive (D:) used for data, but I chose not to back this up.

The target drive is a 550GB RAID5 volume. So size isn't the issue.

I thought using RAID might be causing issues so I disconnected that and connected a single 750GB SATA drive instead. Ran the recovery again - same error

Next I thought maybe it's trying to restore D: (even though I didn't back it up). So I connected 2x 1TB drives - same error again

I have used diskpart to convert the target drive to dynamic and ensure it's MBR which matches the source server. Error persists.



So this is where I'm out of ideas and would be thankful of some advice.

Re: Recovery Failure

Posted: Wed Dec 10, 2014 9:42 pm
by michael.jones
Hello,

It's Michael from Support. Please take a look at the following MS Technet blog post on this error:

https://social.technet.microsoft.com/Fo ... dowsbackup

Re: Recovery Failure

Posted: Thu Dec 11, 2014 4:34 am
by SAFCasper
Thanks Michael, but that post doesn't have a resolution.

The 1TB drive I tried restoring to is brand new (ie. no partitions). The source HDD I have backed up is only 500GB in size (about 180GB of actual data).

I'm currently running another backup of the full system with all recommended selections - and using a different backup drive.

Will try the restore again tomorrow from this new backup and report back.

Re: Recovery Failure

Posted: Fri Dec 12, 2014 7:35 pm
by SAFCasper
Hi again. Just an update.


I tried restoring again using the new backup - with some odd results.

Source Machine
- 500GB OS Drive (Sata)
- 1TB Data Drive (Sata)

Target Machine
- 550 GB RAID5 Volume (15K SAS Drives + Dell PERC 6/i)
- 1TB Sata Drive (Sata)

Now the weird part. If I select "Restore only critical drives" the recovery fails with the same error - Failed to find enough suitable disks for recreating all critical disks

But if I don't select that (ie. restore all drives/volumes) ... it works.

So apparently I don't have enough suitable disks to restore only my critical volumes... but I do have enough to restore my entire system. Hmmm

Re: Recovery Failure

Posted: Mon Dec 15, 2014 9:00 am
by Stuart
Hi there,

It's Stuart here from the BackupAssist team, thanks for posting on our forum.

What you're seeing is directly related to the Microsoft Recovery Environment. When using RAID, the RAID configuration that was backed up still need to be configured on the dissimilar hardware for a full bare metal recovery (based on the critical volumes being recovered). Once you get to Step 5 on page 10 of our RecoverAssist documentation at http://www.backupassist.com/downloads/v ... rguide.pdf then you still need to abide by any drive configuration limitations imposed by Microsoft.

By selecting not to recover critical volumes; you're essentially stating to recover regardless of the configuration.

Essentially; if you're backing up RAID then you'll need to recover to the exact same RAID configuration for best results.