Unable to perform a baremetal restore

This forum is no longer monitored by the BackupAssist support team, but is available to the public to use for assistance with technical issues relating to BackupAssist v7.x.x.

Moderators: michael.jones, casey.burns, Mike D

Unable to perform a baremetal restore

Postby amn70 » Sat Mar 14, 2015 1:15 pm

Running BackupAssist version 7.0 2r2. My primary hard drive died and I replaced it. Then I wanted to to a bare metal recovery but when I boot to the RecoverAssist recovery utility and select the image to restore, while it allows me to select the image to restore which I have on an external hard drive it won't let me click next to proceed. It says I need to boot to the recovery disk or the windows install disk. I thought booting to the RecoverAssist utility was supposed to eliminate the need to make a system boot disk or boot to the windows disk. Whats the point of the RecoverAssist utility if it won't allow the restore proceed. In the end I was able to restore the image created by BackupAssist but had to use the Windows Install disk and use its own Repair utility to to restore the image. That defeats the purpose of the RecoverAssist function.

Once I did finally get the Windows image restored I tried to then restore another image using the Restore feature inside the BackupAssist program but it keeps failing with the error below. Tried doing it to original location as well as alternate location and get the same error. Ended up mounting the VHD file of the image inside Disk Management to gain access to the files I needed and just copied them over. So far BA has proven unreliable. I could have just as well Windows own Backup and Restore and accomplished the same things.

Any ideas why the program failed at both these procedures


Retrying with: LocalDirectory: directory F:\WindowsImageBackup\CSD_Acq\
Starting Backup location connection
Backup location connection Success
Starting Catalogue detection
Catalogue detection Success
Starting restore
No reboot required
Restore failed with exception:

MountToolLib.InvalidVHDException: Failed to create difference VHD. Error#1 (Error.) ---> MountToolLib.Providers.Mountable.VHDMountable.RealSCSIException: Failed to create difference VHD. Error#1 (Error.)
at MountToolLib.Providers.Mountable.VHDMountable.RealSCSIWrapper.CreateDifferencing(String child, String parent)
at MountToolLib.Providers.Mountable.APIMountable.Mount(Boolean readOnly)
at MountToolLib.Providers.Mountable.VHDMountable.CombinedVHDMountable.Mount(Boolean readOnly)
at MountToolLib.Services.MountablesService.ExposeMountable(ExposeMountableEventArgs args)
at MountToolLib.Providers.Mountable.ServiceMountableBase.Mount(Boolean readOnly)
at MountToolLib.Mountables.MountableDrive.PerformMount(Boolean readOnly)
--- End of inner exception stack trace ---
at MountToolLib.Mountables.MountableDrive.PerformMount(Boolean readOnly)
at MountToolLib.Mountables.BaseMountableDrive.Mount(Boolean readOnly)
at MountToolLib.Services.MountToolUIServiceUsingSystemBackupInformation.Mount(IMountableDrive driveDetails, Boolean readOnly)
at CortexIT.Restore.WinImageFileRestorer.mountAllVHDs()
at CortexIT.Restore.WinImageFileRestorer.PreRestoreHook()
at CortexIT.Restore.Restorer.Restore()
at BackupAssistRestore.RestoreObjects.RestoreObject.PerformRestore()
Posts: 3
Joined: Thu Feb 28, 2013 12:59 am

Re: Unable to perform a baremetal restore

Postby gsohal » Mon Mar 16, 2015 3:50 pm

Hi There

It's Gagan from the BackupAssist team. Thank you for posting on our forum.

Sorry to hear that you've issues with the backup software.

The reason for such issues could be the old version of BackupAssist [v7.0.2] you are using. There have been many enhancements and fixes released in the later versions.

To quote, the exception you are getting in the restore console has been addressed in v7.1.0
You can refer to point # 15303 in the following release notes: http://www.backupassist.com/BackupAssist/history7.html

I would recommend you upgrade the software to the latest version i.e. v7.4.6 and then test restore and recovery.
BackupAssist v7.4.6 can be downloaded from the following link: http://downloads.backupassist.com/7.4.6 ... _7.4.6.exe

In case same issue persists then I would recommend you submit the diagnostic report for analysis.
To submit the diagnostic report you will need to log in BackupAssist console > Help > Feedback and Support > Contact Support.

We will review the diagnostic report and revert.

Posts: 97
Joined: Tue Nov 12, 2013 1:53 pm

Return to Technical Support v7

Who is online

Users browsing this forum: No registered users and 1 guest