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1. Exchange Granular Restore overview

The Exchange Granular Restore (EGR) console allows you to restore mail items using Direct Exchange
Injection. The backups used can be created by System Protection, File Protection or File Archiving. This
means the backup you use to protect your Exchange Server can also be used to restore mail items.

Exchange Granular Restore is the recommended tool for restoring mail items for Exchange 2013, 2010 and
2007. It is enabled in BackupAssist when you purchase the Exchange Granular Restore Add-on and supersedes
the Exchange Mailbox Protection solution. This earlier technology was purchased as the Exchange Mailbox Add-

on, and is now bundled with the Exchange Granular Restore Add-on. Both solutions are supported.

Exchange add-on comparison

Feature

Exchange Mailbox Add-on

Exchange Granular Restore

Add-on
Exchange version support 2007, 2010 2007, 2010, 2013
Exchange Server authentication Required Not required
Special backup type Required Not required
Mail Preview (before restore) No Yes

Backup size

Requires additional PST file backup

Part of Exchange Server backup

Backup destination

Local disks only

As supported by backup type

EGR support for backup types -

by server version

File Protection & File Archiving

Backups Windows 2008 Windows 2012
System Protection v v
v v

The Exchange Granular Restore Add-on can restore:

e Mailboxes, mail folders and emails (cannot be encrypted)

e Folders
e File attachments
e Contacts

e Notes, Tasks, Journal items and appointments

Journals, emails attached in other emails and embedded email objects are currently not supported.

Requirements

e BackupAssist 7.2 or later must be installed on the Exchange Server.

e Operating systems: Windows Server 2012/R2, 2008/R2.
e RAM: 256-1024 MB, depends on mail store size and OS version
e May require free space on disk 1.5x the size of mail data being processed.

Exchange Granular Restore is tested for optimal performance up to the following dataset sizes.

e Database size: 500 Gb / Mailbox size: 100 Gb
e Number of messages in one mailbox - 100,000, in the database - 2,000,000.
e Number of mailboxes in the database: 2,000
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2.Backup considerations

Backup user identity

Backup jobs require an administrator account with read access to the data source, and full read-write
access to the backup’s destination. It is recommended that a dedicated backup account is created for
this purpose. The account's details are entered using the Backup user identity option on the Settings
tab, and your backup jobs will be launched using these credentials.

Exchange VM Detection

If your backup job contains a Hyper-V guest with an Exchange Server, the authentication information
for that guest should be entered into the Exchange VM Detection tab on the Selection screen when
you create the backup job. With these credentials, BackupAssist can detect what guests have an
Exchange Server, and list the EDB files available for each guest when you perform a restore using the
Exchange Granular Restore console

What do vou want to back up?

Selections
| Files and Applications | | Exchange ¥M Detection @

Authentication account for Hyper- quests running Exchange
If wour backup job contains & Hyper-¥ guest with an Exchange Server, the authentication
information For the guest should be entered below, With these credentials, Backupissist can detect

what quests have an Exchange Server, and list the EDE files avaikble For each quest when you
perform a restore using the Exchange Granular Restore console,

Username:

Password:

This password should never expire.

Diarnain:

Test

Figure 1: Figure 1: Selection screen - for an Exchange Server on a Hyper-V guest

The Exchange VM Detection tab will appear when the Hyper-V role is installed and running on the
server. If you are backing up multiple Exchange guests, each one should have the same username and
password.

The Hyper-V process is automated but the restore requires both the Exchange Granular Restore Add-
on and the Hyper-V Granular Restore Add-on licenses.

Restore vs. Recovery

A restore is the process of accessing a backup and restoring it to the original (or a new) location, if
your data is lost, corrupted or if you want an earlier version of that data. However, if your computer
cannot start itself, you may need to perform a recovery.

A recovery is the process by which a computer is recovered after hardware has been replaced or an
operating system failure has occurred, and your computer can no longer start itself. To perform a
recovery you need a bootable media to start your computer, and an image backup that the bootable
media can use to recover your operating system, data and applications.

For more information on data recovery, see the Recover tab & RecoverAssist Whitepaper.

Exchange Granular Restore
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3.Creating an Exchange backup

This section explains how to back up your Exchange Server using BackupAssist on Windows
rk‘ Server 2008, SBS 2008 and later operating systems. These backups are used by Exchange
U Granular Restore to restore emails and individual mail items.

@ How to use Exchange Granular Restore is documented in Section 3.

© 1o back up Exchange on a Hyper-V guest for EGR, review the Exchange VM Detection section

Launch BackupAssist and follow the steps outlined below:

1. Select the Backup tab, and click Create a new backup Job
2. Select System Protection, File Protection or File Archiving.

If this is the first time you have created a backup job, you will be asked to provide a Backup user
identity if one has not been defined. See the BackupAssist settings, whitepaper for guidance.

The following instructions use System Protection to explain the Exchange VSS back up process.

£ Home i= Manage EX Monitor [] Reports

& Create a new backup job
m Select the type of backup job you would like to create

Backup l:ﬂ System Protection

for Bare Metal recovery to an old or a new system

Method: Drive Imaging
Backup to Disk [ iSCSIf NAS

D File Protection B Exchange Mailbox Protectior

for historical versioning of files farrestore of email and publicfalders
Method: File Replication Method: Export to PST
Backup to Disk [ iSCSIf NAS [ Rsync Backup to Disk

@ Requires additional license

@ File Archiving % SQL Server Protection

for keeping long-term archives far near continuous database protection

Method: ZIPG4 Method: SQL Backup
Backup to Disk [ iSCSIf NAS [ Tape [ Blu-ray / ... Backup to Disk
B Requires additional license

Figure 2: New backup job — backup type selection screen

Instructions specific to each backup type, can be found in their respective whitepapers.

Remember: It is important to maintain both daily and archive (historical) backups as part of your backup
strategy. To learn more, see the Backup tab whitepaper’'s Manage section on scheduling

Exchange Granular Restore
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3. Selections: The selections screen is used to select the data and applications that you would like to
back up. Any local Exchange Servers detected will be displayed here as application containers.

© An Exchange VM Detection tab will be available if you are backing up an Exchange VM guest.

You can select an entire VSS application or choose individual components. To back up your
Exchange Server, select the Microsoft Exchange container.

If your local Exchange Server is not listed in the Selections screen, try restarting Exchange and the
VSS service and then click the Refresh button in BackupAssist.

£ Home i= Manage 4 Monitor [] Reports
7~ J] System Protection Wizard
&kj What do you want to back up?
Backup Selections

O i‘ Back up the Entire Systermn (Recommended)

@H.~ Back Lp selected items only

e Refresh [ | Check selections E[ Estimate size O Key

El a f Critical volumes (tick For Bare Metal Recovery) Name | Type | Slzel Last Mnchﬂedl
; [F'% Local Disk () 2 Microsoft Exchange Server
|l Data and Backup Yolumes
§4 Share Paint Services
3 5al server
A Micrasaft Exchange - €
=[] Microsoft Exchangs Server - i)
2% 1 Microsoft Information Store

‘j Third Storage Group

4 |

0 Sorme volurne(s ) have been selected to ensure backup of yvour Application Selections.

< Back ][ Next > ][ LCancel

Figure 3: New backup job - Exchange Server VSS selection

e For System Protection backups, VSS applications will be backed up as part of a Backup up the
Entire System selection. In the example above, Back up selected items only, was chosen and the
Exchange Server application container was selected.

e For File Protection, File Archiving and System Protection backups, the top level Microsoft
Exchange and Exchange Server application containers should be selected.
4. Destination media: The destination screen is used to select the type of media that you want to

back your data up to. This step’s name will change to the media type selected, when you click next.

Select a device for your backup destination, and click Next.

5. Schedule: This screen is used to select when and how you would like the backup job to run, and
how long you would like the backup to be retained for. A selection of pre-configured schedules,
called schemes, will be displayed. Select an appropriate scheme, and click Next.

To learn more about backup schedules, refer to the Backup management section below.

For detailed information on scheduling options and customizations, see the Backup tab user guide.

Exchange Granular Restore
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6. Set up destination: This screen is used to configure the location of the media selected in step 4.

Configure your backup destination, and click Next.

7. Notifications: Once a backup job has completed, BackupAssist can send an email to inform
selected recipients of the result. This email notification can be enabled during the creation of a
backup job, if the mail server has been configured.

To send email notifications, you will need to configure an SMTP mail server for BackupAssist. See
the Backup tab user guide for more information.

To enable email notifications:
a. Select, Add an email report notification.
b. Enter recipients into the Send reports to this email address field.

c. Enter recipients into the Also send reports to this email address field. You can then select
the condition under which the email should be sent, using the drop-down box.

8. Prepare media: If you selected a portable media device as your backup destination (such as an
external HDD or a RDX drive) you will be given the option to prepare the media for BackupAssist.
BackupAssist will write a label onto the media so that it can recognise what media has been
attached, and determine if it is the correct media for your backup schedule.

To enable media detection:

a. Select, Let BackupAssist keep track of your media.

b. Select what you would like BackupAssist to do, if the wrong media is inserted.

c. Select what you would like BackupAssist to do, if new or unrecognized media is inserted.

BackupAssist will display all removable media that are currently attached, along with a text field
and drive designation drop-down box, which can be used to provide a label for the media.

To prepare your media:

d. Enter the name and drive designation to be used for each media device listed.

e. Select Prepare for each media device listed.

BackupAssist will now write the label to the media so that it is able to recognize the media and
ensure that the correct media is being used on the correct day. For example, if you put an RDX

drive in on Tuesday but it was labeled Wednesday, BackupAssist will warn you that the incorrect
media has been detected.

9. Name your backup: Provide a name for your backup job, and click Finish.

» Your Exchange Server (VSS) backup job has now been created.

Important: Once a backup job has been created, it should be reviewed and run using the Manage
menu. This menu provides additional options to configure your backup.

Important: Once the backup has been created, it should be checked. You can check the backup by
performing a manual test restore, or using the Backup Verification feature. A manual restore is the only

way to fully test a backup, and regular manual restores should be part of your backup solution.

Note: To enable the Exchange 2007 VSS writer, please refer to this blog article.

Exchange Granular Restore 5
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4.Exchange Granular Restore

Restore Add-on. This restore-based solution allows you to use System Protection, File

g Exchange Granular Restore (EGR) is enabled with the purchase of the Exchange Granular

Protection and File Archiving backups to restore individual mail items.

© Important considerations:

e When you restore individual emails or a mailbox, the word RESTORED will appear in the Subject
line of every email. This is enabled by default and can be turned off using the EGR Options menu,
by selecting Options > Add RESTORED to exported item > No.

e BackupAssist's restore Home page can display backups of Exchange databases inside Hyper-V
guests so that mail items can be restored using the Exchange Granular Restore console. The
Hyper-V process is automated but the restore requires both the Exchange Granular Restore Add-on
and the Hyper-V Granular Restore Add-on licenses.

e If you launch the EGR console from the Tools menu, you will need to manually mount the Data
container to locate an EDB file inside it. To mount a data container, please refer to our blog article.

To restore individual mail items, follow the steps below

Step 1 - Locate the Exchange backup

a) Start BackupAssist and select the Restore tab

The Restore tab has a Home page and a Tools menu. The Home page is the default screen and the
recommended starting point for performing a restore. The Tools menu should only be used by

experienced administrators or users being assisted by technical support.

b) From the Restore Home page, select Exchange

4« Home ¥ Tools

Select what you would like to restore

DI Files & Folders
Restore
Hyper-V

=] SQL
—

5 Volumes

@ Learn more about Restore >

@ Restore data files and applications

g Exchange

Applications

Windows SystemState /
Active Directory

Figure 4: Restore tab - Home page

This will open the Restore > Exchange screen and display the restore options available.
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¢) From the Restore > Exchange screen, select Exchange Granular Restore (.edb)

X Toals Eiea
[§ Restore »Exchange

e Exchange Server Restore
=]

Restore an entire Exchange Server or individual Storage Group(s) - for Exchange 2013, 2010, 2007, 2003

N

Restore Exchange Granular ' Mailbox Protection
_| Restore (.edb) n Restore (.pst)

Restore individual mail items or entire Restore individual mail items from Exchange
mailboxes from any standard Backup - for Mailbox Protection backups - for Exchange
Exchange 2013, 2010, 2007 2010, 2007, 2003

Figure 5: Restore Exchange page - selection screen
Backups made with BackupAssist 7.1 and later, that contain Exchange databases, will be displayed.

d) Select the database file to restore from

e The backups displayed can be filtered using the time period tabs.
e Selecting a backup will expand its contents and display each .edb database inside the backup.

When you select the required database file, the Exchange Granular Restore console will start and
open the .edb file. A progress window will appear while the database is opening.

Backup Help 7

'« Home ¥ Tools

@ ... Exchange » Exchange Granular Restore (.edb)

4 Local Storage Groups 1 backup(s)

Last 7 days I Last 30 days | il Custom I

Show backups between p1josfzo1s x| and prjosfeoz x|

@ Jab Diate/Time Media
D File Protection - Exchange Server backup 21J05/2013 10:00 PM [ cehkesty

C:\Program Files\Microsoft\Exchange ServeriMailbox\Second Storage GroupiPublic Folder Database.edb

Restore

| C:\Program Files\MicrosoftiExchange ServeriMailbox\Second Storage Groupiriky . edb

Figure 6: Exchange Restore - backup and database selection

Once the .edb file has been opened, you will be able to view the mail items inside it.

Note: If you open Exchange Granular Restore from the Restore > Tools menu, you can use EGR to browse
to, an open, a PST or OST file. You can then search the PST or OST file, and restore the selected mail items.

Exchange Granular Restore
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Step 2 - Locate the mail items

The Exchange Granular Restore (EGR) console has a Browse mail tree and a Search field to help locate,
preview and select the mail items that you want to restore.

If you open EGR from the Restore > Tools menu, you can open a database using the Open Exchange DB button.

Console options
Both the Browse and Search functions can use the following options.

o Display filter: Press CTL+F and a Filter field will appear under the list of currently displayed mail
items. Select the Subject, From, To, Attachments, Created or All filter, and enter the text to filter by.

e Restore Deleted items: Display hidden deleted items, is available in the Options menu, and
selecting it will give access to previously deleted mail items. This is not mail from the delete items
folder but mail items that are no longer present. The database will reload when a selection is made
and the deleted items will and have a flag to indicate that they are a deleted item.

= Deleted items from Exchange Server 2007 are stored in their original folders.

= Deleted items from Exchange 2010 and 2013 are stored in the folder Deletions. These items
cannot be restored to live Exchange Server database. It is recommended that these items are
exported to a PST file and then imported into the live Exchange Server.

o Display time: Select Display time, from the Options menu and select Local or GMT. This applies to
the date in the properties tab of a mail item. The database will reload when the format is changed.

Using Browse

The Browse mail tree is displayed in the console’s left pane. Browsing for the items you want to restore
is ideal when you know their location.

File Options Help

Exchange Granular Restore

Foe king [~]] ;[_flﬁ
[ Browse | Destination
[ ]4j Maibox Data edb Type  Sublect Sigtus  From To Mfochm... | Created Mo Exchange server
-[C159 /o=MoSuchEmail/ou=Exchange Adminis attached
= = Toyans cry me ten th.. & Pakeman e Clark; rew Wat: Dali .. g -
15 Aex Clark [[]e4 CASSANDRACH T Lend me ten th V' Kyle Pak Alex Clark: Ancrew Wat; Dal 16 Aug 21
T ]34 AJAX Thersites THERSITES Agamemnon-ha... «'  Brian Rudy Raid; Robert Rise: Susa... 16 Aug 2
159 Andrew Watt Attach a server to enable
D;:"i Andy Kort [ BOYSir rmy lord would " Susane Tyler Dalia; Tim Goodler; Kyle Pake.. 16 Aug 2 drag-and-drop injection of
[ Bian [T]24  PANDARUS Asses fools dotts chaff and ' Bran Fudy Raid: Robert Rise: Susa. .. 16 Aug 20 messages f;d fﬂ‘_l:“m‘fmm
IEET™ ()24 PANDARUS That's Hector that that ' Susane Tyler  Daia; Tim Goadler: Kyle Pake.. 16 Aug 21 Bechange, e
-[C159 John [C1E3  CRESSIDA Who were those went ' Maria Woods Tim Goodler; Robert Rise; Kyl... 16 Aug 21
Dg Juliet Capulet [C1E3 TROILUS Call here my varlet: ' Maria Woods Rabert Rise; Alex Clark: Andr. Q x2 16 Aug 20
[C159 Kyle Pakerman [C1E3 In Troy there lies the ' Dala Romeo Mortague: Kyle Paker... 16 Aug 2/
-5 Luise [T]E2 PUBLIUS What is your wil ' Richard Kyle Pakerman: Maria Woods... 16 Aug 21
|:|.=J Waria Woods [[JE KING We lost 2 jewel '  Susane Tyler  Andrew Wat: Dalia; Richard: ... 16 Aug 2
Drﬁ_ M.\chael [C]E  How now good fellow Wouldst " Susane Tyler Brian; Dalia; Maria Woods; Ri.. 16 Aug 2
059 Rechard [/ TITUS Come Marcus /' MaiaWoods  Anchew Wat; TmGooder, D.. (] x2  16Aug2l
Ec‘ Robett Riss 11 SATURNINUS Why lords what wrongs W AexClark Maria Woods; Michael; And . 16A1321
= .:igmsl M:"‘E?;; )& CHIRON Demetrius here's the son +  Daia Romeo Mortague; Andy Kort . 16 Aug 2l
— Calendar (135) [C]53  MESSENGER Worthy Andronicus '  AndrewWait  Fichard: Romeo Montague: *2  16Aug?l
Sa] Cortacts (56)
= 4o 16 Aug 21
g g,:ze?mhems © [ Where: Al - | 1 selectarsttoms | ¢ 16 A2 -
S
3 Inbox (2115) [ [ ] [t
A Joumal (1)
3 durke E-Mail (0) TITUS Come Marcus &
Netes (0]
aria Woods Aftachments: Wealth of Nations-951.b¢
= oo (3)) Maria Waod
L3 Sent hems (28) Date: 16 Aug 2012, 18:32 E
¥ Tasks To: Andrew Wait, Tim Geodler. Dalia; Rudy ’
7 Tasks © Shakespeare-1651.0¢
Dé Rudy Raid Baid @1eana Tular lnhn Michssl Kils
-[C] &9 Susane Tyler v bi |
7] £9 SystemMailboxd78d3a78c-3671-42c3a¢
Fa TITUS. Come, Marcus, come; kinsmen, this is the way
Dd Tm Goodler Sir boy, let me see your archery;
Look ye draw home enough, and Yis there straight
Terss Astrea reliquit, -
< n 3 Preview | Properties
Completed | Selected: 0 nodes, 0 items |

Figure 7: The Exchange Granular Restore console

e Selecting a folder will display the individual mail items inside it, on the pane to the right.
e Selecting a mail item will preview its contents in the pane below it.

Exchange Granular Restore
© Cortex 1.T. 2001-2015 User Guide: Version May 26 2014



Backup

Using Search

The Search field is ideal when the location of a mail item or the number of items to restore is
unknown. When a keyword search is performed, a new tab with a browse tree will open containing
only the mailboxes, folders and mail items that match your search criteria.

The search word must be a whole word.

To perform a simple Search, enter the search word into the field, click the search icon and the Search
tab will open in the console. This Search tab will contain all items in the database that contains the
word you entered.

To perform an advanced Search, select the arrow by the Search field to display the advanced search
options. The Search in field will default to the entire database. To search inside specific mailboxes or
folders, select the Search in field and use the dialogue window to select the required containers.

The following search options are available:

e Has words, searches for mail items that have words or phrases entered into the field.

e Doesn't have, searches for items that do not have words or phrases entered into the field.

e Has attachments, will search for items with attachments.

e  From, will search for keywords in the From: field.

e To, will search for keywords in the To: field.

e Subject, will search for keywords in the Subject: field.

e Date range, can be used to set a specific date range. A beginning and end dates must be set.

File Options Help

Exchange Granular Restore

B o0 9
() Browse |Saard1 king % Entire database Destination
=-[]v3 Search:king Type  Subject Stetf  Haswords: kding No Exchange server
£33 NexCsic 07 [C] 2 JAQUENETTA God bless the King KING What presert h Doesn't have: ziEsigi
159 Andrew Wat (75) ! od bless the King present ha /| Doesn't have:
155 Andy Kor (57) CIED KING Lat fame that al v ] Has sttachments Atach a serverto enable
&[] &3 Brian (55) [T1E1 KING PHILIP So by a roaring tempest on the flood A whole. L - drag-and-drop injection of
]2 Calendar [C1E8  KING JOHN Ta ELINOR So v From: messages and folders from
2= @ ~ source mail store into live
[FIE3 Inbax (48) |12 KING Charles | wil play no more “ To: Eie
-[C]£5 Dalia (62) [ KING EDWARD Once more we: v b
[T] 539 John (64} [ The Beggar and the King ¥ Subject:
-[C] 59 Juliet Capulet (64) 1 inthe reign of king ¥
+[C] 9 Kyle Pakerman (62) [C1E2  Inthe anciert dominions of the king o Daterange: O to [Ehd
Dg Luise (58} [7]:4  KING EDWARD Seize on the shamefacd ~
-] =9 Maria Woods (59) [/ KING HENRY Master Lisutenant now “ [ Search | [ Gear |
[155 Michael (1) [C1E1 KING HENRY My lords look “
Eg E‘n"::drd’:t“) " i1 KING HENRY Ses Buckingham Somerset /" Fiober s Fomeo Woriagus; Michasl: B
D@ Ro MST_‘: ) 62 [C15 KING HENRY How now What news Why com'st thou in %"  Romeo Monta... John; Luise; Richard; Michae!
Dﬁ Ru:yeoﬂm:(&aﬁfue [C1E2  KING HENRY I muse my Lord of Gloucesteris not come Ti... &  Dalia Kyle Pakerman: Michael: Tim ...
= = at tidings with our cousin ingham B... rew Wait e Pakerman; Luise: Romeo... L
F1&§ Susane Tyier (63) [T1:4 KING HENRY What tid h Buckingham B ~  Andrew W Kyle Pak Luise: Ro
D@ Tim Goodler (54) [ KING HENRY For my part +"  Romeo Monta... Rudy Raid; Andrew Wait; Mar...
[C1E1 KING HENRY Have you peustd the "  Susane Tyler  Brian; Dalia; Andrew Watt; Ru
[T KING HENRY We charge you on allegiance to oursef To «/  Romeo Monta... Michasl; Susane Tyler. Brian:
[l PISTOL Qui va la KING %"  Maria Woods  Dalia; Robert Rise; Tim Good|
[C1E2  FRENCH KING Tis certain he hath passd the river Somme... %'  Richard Brian
[14 KING HENRY How sits the " Robert Rise Maria Woods: Luise: Brian: R... Q x
[C]E  CLARENCE Doth the King call WARWICK «"  Richard Brian; Dalia; Andrew Watt; Ru..
[T KING Now lords if God doth give successful end %"  Romeo Monta... John; Brian; Kyle Pakerman;
[C1  KING Go cal the Earls of Sumey and of Wanwick; But ere t "  Susane Tyler  Juliet Capulst; Alex Clark; And
b= Doug Am gentlemen to ams for | have thrown A brave def. " Kyle Pakeman Alex Clark: Andrew Wat; Dali...
b= King My blood hath been too cold and " Dalia Brian
[C12 Laer Where is this king?- ' TimGooder  Erian il
Y SO T - - . P PR PV S
4 . = | +
Page ofl| b M O 100 messages per page
Completed \ Selected: 0 nodes, 0 items

Figure 8: Exchange Granular Restore console - Search tab

If a search does not match any items, review your search parameters and run another search.

Once you have located the mail items that you want to restore, select them using the tick box. Once
you have selected an item to restore, the restore type icons in the menu will become active.
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Indexing Modes

Database indexing can be disabled or cancelled via the Options menu. If indexing is disabled, a
database search will not be possible. Two indexing modes are supported: Light and Full.

e Light indexing (default): Limits the searchable information to the following fields: From, To, Subject,
Date range. A To field with a long recipients list and message bodies will not be indexed.

e Full indexing: This mode will take longer to index as it allows a search across the entire database.

Step 3 - Perform the restore

Once you have located the required mail items, there are three ways they can be restored using
Exchange Granular Restore: Restore to original location, Restore to alternate location and Export to PST.

Option 1: Restore to original location

= This option will restore the selected mail items back into their respective mailboxes on the
ry original Exchange Server.

R

To perform the restore, follow the steps below:

a) Select the Restore to original location button.

A Restore to original location window will open. The domain name of the server running Exchange
will be automatically detected if you are on the same domain.

b) If no Exchange Server was detected, manually fill in the Server name field and click Reconnect.

It is possible to restore data to someone else’s mailbox using Exchange Impersonation. To do this,
the current user credentials must have Exchange Impersonation access to the destination mailbox.

Server name:

Server not detected. The destination Exchange Server is
detected automatically using the
current Active Directory domain. If

Details: necessary, you can change the
server name, and attempt 2 manual

Source mailbox 'egr user does not exist on the destination server: 13 folders will not be Restored. Reconnect.

Curment uzer: CORTEXIT

Mailbax GUID: f136feb4-Dbad-42ea-37e1-327bb 65 Sefd The current user must be a member

Active Directory connection: OK of the same domain a5 the target

Mailbox found in Active Directony: No aclﬁange .|93rver andt_sh{:uld ha"’?

Ermor message: Cannot find mailbox in Active Directary EACHENge MOSSANEUAT 366835 10

the destination mailboxes.

c) Select Restore, to begin the restore process.

A progress window will be displayed during the restore. The window shows the number of folders,
messages and errors. You can enable and disable the progress window in the Options menu.

e The restore can be cancelled by clicking the Cancel restore button.
e The progress window can be reopened by clicking Progress bar on the status panel.

e Selected items will be copied into their original locations on the live Exchange Server. If
selected items cannot be matched to a destination mailbox, they will not be restored.

e The destination Exchange Server is detected automatically using the current Active Directory
domain. If necessary, you can change the server name and attempt a reconnect.

Exchange Granular Restore
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Option 2: Restore to alternate location

7

To perform the restore, follow the steps below:

a) Select the Connect to Exchange Mailbox button.

This option will restore the emails and mail items from the offline backup to a live Exchange
database that is different to the one they were backed up from.

The Connect to Exchange Mailbox button will open the connection dialog box, which is used to

provide the Exchange Server name and the authentication details (User logon) for a specific

mailbox on that server. This authentication process can be repeated for additional mailboxes.

The Restore to alternate location button will become active when a connection has been made.

Exchange Granular Restore
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Figure 9: Restore to alternate location — connection authentication

Enter the following details into the connection dialog box:

e Server name - Domain name Exchange Server or IP address
e Mailbox user name - This will identify, authenticate and open the applicable mailbox.
e Password- The password for the applicable mailbox.

If Use current Windows credentials is selected, the existing user's Windows password will be used.

If Exchange Impersonation is selected, enter the SMTP address of the mailbox that you want to
connect to. Exchange impersonation must also be configured on the Exchange Server.

Once the connection has been made, the mailbox you have authenticated to will appear as a
mailbox tree in a new pane called Connected Mailboxes. You can open a preview pane for the
destination mailbox tree by selecting the Show item list and preview icon (CTL+R), to the right of
the Connected Mailboxes pane.

b) Restore mail items to an alternate location

There are two ways to restore mail items to the alternate location: drag and drop and the Restore
to alternate location button.
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Drag and drop

Drag and drop mail items from the EDB database backup, into the live Exchange mailbox that you
have connected to.

e The hierarchy of the data being dragged will be recreated inside the destination folder.

e You can create a new folder in the live mailbox by right clicking the mailbox or a folder. Note,
you cannot delete or rename a folder once it has been created.

File Options Help

Exchange Granular Restore
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Restore to alternate location button

Click the check-box next to items that you want to restore and select the Restore to alternate
location button. A dialog box will open and allow you to select a destination folder on one of the
connected mailboxes. Make your destination selection and select OK to begin the restore

e The data hierarchy will be restored automatically.
e The root of hierarchy is the closest common parent item.

Source mail items and destination folder compatibility

Not all types of mail items can be restore to all types of destinations folders. The following table
shows the compatibility matrix of source mail item types and destination directories.

Item type *Mail folder | Journals Notes Contacts Calendar Tasks
Message Y Y Y Y Y Y
Journal Y Y Y Y Y Y
Sticky Note Y Y Y Y Y Y
Contact N N N Y N N
Calendar N N N N Y N
Task N N N N N Y

* The Mail folder includes Deleted Items, Drafts, Inbox, Junk, Outbox and Sent.

If some or all of the selected items cannot be restored (using drag and drop or clicking the Restore
to alternate location button) to the destination folder, then an error message will be displayed.
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Option 3: Export to PST

~” Export to PST will save your selected data in a PST file, which can be opened by outlook to
@[ access the mail items.

To perform the export, follow the steps below:

a) Confirm the Personal Storage Table (PST) format
You can choose Unicode or ANS/ encoding for the PST output file using the Options menu.

The Exchange Granular Restore console exports each mailbox into a separate .pst file named:
“Restore NNN <Mailbox Name>[ VVV]. pst”, where NNN is the current recovery session identifier
and VVV is the volume number, in case the PST file has to be written in more than one volume.

With large exports, there can be more than one PST file. Additional files are created automatically
when the file size limit is reached. The size limit depends on the output file encoding.

e For ANSI PST files, the size limit is 1 GB.

e For Unicode PST files, the size limit is 10 GB.

e A maximum of 15,000 messages can be restored into the PST file.
e When this limit is reached, an additional PST file is created.

b) Select the, Export to PST button

This button will become active once the mail items have been selected.

c) Select the destination.

You will be asked to select a folder or create a new folder. After selecting the new or existing
folder, the export will begin.

You will be shown a progress window during the export. The window shows the number of saved
mailboxes, folders and messages. The export can be cancelled by clicking the Stop Export button. If
you close the progress window, it can be opened again by clicking the status panel’s progress bar.

Selected data will be saved into pst file(s). To start the export select the
destination folder or create a new one and click OK. The export process will start

immediatehy.
£ Recycle Bin o
> . DOCS
4 | EGR
> ) EGR il
> EGR-wireframe E
> mail i
. mail itemns restored
> . NEW HELP -
PST Encoding: | Unicode -

o J o |

The items selected (even if you only selected one item) will be exported as a PST file.
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d) Open the exported mail items in Outlook.

1. Click File > Open and choose Open Outlook Data File.
2. Browse to the PST file that was exported, then select it and click OK.
3. The PST file will appear in Outlook as a container.

OETEY Outlaok Today - Micrasaft Outlook
w Home Send / Receive Folder View
= 0| Open Outlook Data File ==
A Open Calendar [Dfee=r !
£+ ﬁ Open a calendar file in Outlook @(}‘-\@ » Libraries » Documents » « [ 43 ][ Search Documents ol
[Esasss
Info Organize = New folder = 0 @
Open 4 —Eﬁl‘ Open Outlook Data File ] Recent Places = Documents libra ry )
_— /| Open an Outlook data file [.pst) i o] Arrange by:  Folder ~
Print — w4l Libraries .
[% Documents | | Name Date modified =
Help & Music |- 2] Recovery 001 - Juliet Capulet 8/24/20122:22PM  C
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ULOCE‘D\SK(E:J = “\11 [ Dy v, % SO ,er;[, Ty | @A N0 T N ’r
File name: Recovery 001 - Juliet Capulet + [Outlook Data File -
Tools - [ oK J l Cancel ]

Figure 10: Opening an exported PST file in outlook

e) Restore the exported items to the Exchange Server.

Items extracted from an offline Exchange mail store can be restored to a live server. Make sure you
have Microsoft Outlook and access to the mailbox that you want to restore the mail items into.

1. Open the PST file that contains the exported mail items.

2. Open the mailbox that you need to import the data into.

3. Drag-and-drop the item them back into their original folders. They will be automatically
synchronized with the live Exchange Server database.

Drag Your Fa eF Here <
_________________________________________________________________________________ Search Inbox [Ctri+E) e
4 Fxchange Mailbox Arrange By: Date Mewest on top —
L] Inbox =
[ sent Items %} 4 Last Week
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[d Drafts
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L@ Junk E-mail N
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Restored Mail = John Thu 8/16
(3 Restored Mai Whilst the world is thus i

[ RSS Feeds
[ search Folders
[ Shortcuts

.| Robert Rise Thu 8/16
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[ Conversation Action Settings | Susane Tyler Thu 8/16
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Figure 11: Restoring a PST file to an Exchange Server.
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5.Exchange backup management

:— Once you have created a backup job, you can modify the settings and access advanced
® e configuration options using the Manage menu.

To access the backup management screen:

1. Select the BackupAssist, Backup tab.

2. Select Manage from the top menu. A list of all backup jobs will be displayed.
3. Select the backup job you want to modify, and select Edit.

4. Select the required configuration item on the left. Key configurations are described below.

To learn more about the backup management options, see the Backup tab whitepaper.

Scheduling

Selecting Scheduling will display the Scheduling options. You can use this screen to change the
default time and days of your scheme’s daily backups. If you selected a scheme with archive backups
(e.g. weekly, monthly), you can specify when each archive backup will run. The current scheme is
shown, along with two pop-up menus: Select a new schedule and Customize schedule.

Select a new Schedule: This will display the pre-configured backup schemes that you chose from
during the creation of your backup job. The selections available will depend on the type of destination
media you have selected. You can select a different scheme using this option.

Customize schedule: This selection can be used to modify each backup within your current schedule.

For additional information on the Scheduling screen, please refer to the Backup tab whitepaper.

Data container options

If you are using a System Protection backup, you can modify the size settings of a Data container, if
the container does not exist. For example, if the backup job has not been run or if the container has
been manually deleted.

To modify the size select Destination and go down to Data container options:

e Container size (GB): Use the up and down arrows to set the size of the Data container.
e Use all available space: Tick this box and all available space on the destination device will be used
by the Data container, up to 2TB.
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